Colleague/Web Advisor/Self Service/Make A Payment Maintenance
Scheduled for Aug 13, 06:00 - 09:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 16, 2020 - 09:16 EDT
Scheduled
IT will be performing systems maintenance on the Colleague environment. The following systems or applications will be unavailable during the maintenance outage: Colleague, WebAdvisor, and Self Service for students including Student Planning and Make-A-Payment.
Posted Jan 15, 2020 - 14:31 EST