Microsoft Outlook (Desktop Application) Connectivity Issues
Incident Report for Northwood University
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 09:35 EST
Investigating
We are currently experiencing connectivity issues with the Microsoft Outlook desktop application that is impacting the ability to connect to public folders.

The problem arises from every Outlook desktop application client attempting to connect to the Public Folder database, regardless of whether users actively use it. As a result, many users are encountering a persistent security dialogue box that prompts for credentials but does not disappear after entering them.

To mitigate this issue, users can exit out of the security dialogue box to continue sending and receiving emails. However, if that does not work or you prefer uninterrupted access to your emails, we recommend accessing your inbox via the web interface at my.northwood.edu and using the Web Mail link to view your inbox until the problem is resolved.

We apologize for any inconvenience this may cause and assure you that our team is actively working to resolve this issue. Thank you for your patience and understanding.
Posted Feb 28, 2024 - 10:18 EST
This incident affected: Messaging & Collaboration Services (E-Mail).