Library Resource Outage
Incident Report for Northwood University
Resolved
This incident has been resolved.
Posted May 26, 2020 - 12:11 EDT
Investigating
IT is currently experiencing an issue with some of our library resources. When accessing the resources users may receive an unusual message to login, this would indicate the resource is not working at this time.

IT is quickly working to resolve this issue.
Posted May 22, 2020 - 11:55 EDT