Investigating Perceptive Content / Image Now Outage
Incident Report for Northwood University
Resolved
This incident has been resolved.
Posted Apr 13, 2018 - 09:49 EDT
Investigating
IT is currently investigating a Perceptive Content/Image Now outage.

To report issues, please call the IT Help Desk at 877.209.HELP.
Posted Apr 13, 2018 - 08:47 EDT