Investigating Inbound Mitel Phone Outage
Incident Report for Northwood University
Resolved
This incident has been resolved.
Posted Jun 12, 2020 - 11:01 EDT
Investigating
We are currently experiencing intermittent issues with inbound calls, due to asbestos abatement we are not able to enter and troubleshoot the area. Please be patient as we wait for the building to be cleared at some point tomorrow 6/12.
Posted Jun 11, 2020 - 10:03 EDT
This incident affected: Voice Services (Mitel Telephones).