Unable to access Microsoft 365 services or features
Incident Report for Northwood University
Resolved
This incident has been resolved.
Posted 4 months ago. May 02, 2019 - 18:38 EDT
Identified
Users may be unable to access Microsoft 365 services or features such as SharePoint Online, OneDrive for Business, Microsoft Teams, Stream, Power BI, Planner, Forms, PowerApps, and Office Licensing.

Microsoft has identified a potential Domain Name System (DNS) issue that could be contributing to the problem and is working to develop an action plan to mitigate the impact.
Posted 4 months ago. May 02, 2019 - 17:13 EDT
This incident affected: Application Services (Office 365).