Admin WiFi Authentication Issue

Incident Report for Northwood University

Resolved

This incident has been resolved.
Posted May 14, 2026 - 11:27 EDT

Investigating

We are currently experiencing an authentication issue that is preventing users from connecting to the Admin WiFi network. Our team is actively investigating the issue and working toward a resolution. We apologize for the inconvenience and will provide updates as they become available.
Posted May 14, 2026 - 10:08 EDT
This incident affected: Midland Campus Wireless Network (WiFi) (Midland On-Campus Network (WiFi)).