Intermittent Experience/my.northwood.edu Access Issues

Incident Report for Northwood University

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 13:01 EST

Investigating

Some users may experience intermittent access issues when logging in to my.northwood.edu and receive a "404 – User Not Found" error.

Access issues affect some users, but not everyone. We are currently investigating the cause and working with the vendor to restore full service.
Posted Jan 05, 2026 - 11:44 EST
This incident affected: Application Services (Ellucian Experience, My.Northwood.edu/Blackboard).