We will be undergoing scheduled maintenance during this time.
Posted Jun 04, 2025 - 15:57 EDT
Scheduled
IT will be performing systems maintenance on the Colleague environment. The following systems or applications will be unavailable during the maintenance outage: Colleague UI.
Posted Jun 04, 2025 - 15:07 EDT
This scheduled maintenance affects: Application Services (My.Northwood.edu/Blackboard).