Wi-Fi Outage Impacting Campus Connectivity

Incident Report for Northwood University

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 13:47 EDT

Investigating

An intermittent issue is affecting the "northwood" Wi-Fi network across campus. Users may experience difficulty registering devices or no connectivity.

IT is working with the vendor to diagnose the problem and restore full service as quickly as possible.
Posted Mar 18, 2026 - 13:48 EDT
This incident affected: Midland Campus Wireless Network (WiFi) (Midland On-Campus Network (WiFi)).