Campus Wi-Fi Disruptions – Mitigation in Progress

Incident Report for Northwood University

Monitoring

Wireless services are currently stable, and no widespread outages are being observed.

While the underlying issue has not yet been fully resolved, mitigation remains in place and performance is being closely monitored.
IT is planning targeted troubleshooting and infrastructure upgrades after final exams to address the root cause without disrupting academic activities.
Posted May 01, 2026 - 09:09 EDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 17, 2026 - 10:51 EDT

Identified

We are aware of the “admin” and “northwood” wireless connectivity issues that began the evening of April 10, 2026, and have continued to impact users across campus. We understand the inconvenience this has caused.

Our team has identified that a recent firmware upgrade from our wireless vendor has introduced an issue related to memory utilization, which is impacting overall system stability. We are actively working in coordination with the vendor to address and resolve this matter as quickly as possible.

In the meantime, we are implementing mitigation measures to improve performance and reduce disruptions while a permanent fix is being determined.

We appreciate your patience and understanding as we work toward restoring a more stable and reliable wireless experience for everyone. Further updates will be shared on status.northwood.edu as they become available.

If you continue to experience persistent connectivity issues, please submit a network support request so we can assist and track affected areas more effectively:
https://northwood.teamdynamix.com/TDClient/1948/Portal/Requests/TicketRequests/NewForm?ID=ePuluBXc0xQ_&RequestorType=Service
Posted Apr 10, 2026 - 18:00 EDT
This incident affects: Midland Campus Wireless Network (WiFi) (Midland On-Campus Network (WiFi)).