Maintenance/Firewall

Scheduled for Jan 20, 12:00 - 13:00 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jan 06, 2026 - 09:49 EST

Scheduled

Hello Team,

We will be conducting a scheduled firmware upgrade on our firewall to improve security, stability, and performance. There should be minimal downtime. If you experience any issues after the upgrade, please contact the IT Helpdesk. Thank you for your patience as we enhance our infrastructure.

Best regards,

Information Security Team.
Posted Jan 06, 2026 - 09:20 EST