Identified AT&T Phone Outage
Incident Report for Northwood University
Resolved
This incident has been resolved.
Posted Jun 04, 2020 - 13:26 EDT
Identified
IT is aware that all calls coming into and out of the university are currently down. However, we are unable to resolve this physical issue until the water recedes in Midland and we can get back on campus. No ETA on restoration.

In the meantime, check out our Knowledge Base for tutorials and answers to common IT questions. Still can't find an answer? Please submit your IT requests 24/7 by using our IT Client Portal at https://bit.ly/2WNz4ID
Posted May 20, 2020 - 08:58 EDT
This incident affected: Voice Services (Mitel Telephones).