All Systems Operational
Application Services Operational
Datatel/Colleague Operational
My.Northwood.edu/Blackboard Operational
Office 365 ? Operational
Perceptive Content/ImageNow Operational
Recruit Operational
Self-Service ? Operational
WebAdvisor Operational
Make-A-Payment Operational
Turnitin Operational
VPN ? Operational
Messaging & Collaboration Services Operational
E-Mail ? Operational
Microsoft Teams (Instant Messaging & Collaboration) Operational
Blue Jeans (Meeting Rooms) Operational
Blue Jeans (bluejeans.com Access) Operational
Blue Jeans (Dial-In Access) Operational
Blue Jeans Network BlueJeans Events Operational
Blue Jeans Network Scheduling Operational
Share Drives (Personal & Departmental) Operational
Midland Campus Network (Wired) Operational
Adult Degree Program Building (ADP) Network (Wired) Operational
Baseball Diamond Network (Wired) Operational
Bennett Sports Center Network (Wired) Operational
Church Family Administration Building (CFAB) Network (Wired) Operational
DeVos Graduate School Network (Wired) Operational
Doan Welcome Center / Admissions Network (Wired) Operational
DuBois Hall Network (Wired) Operational
Freedom Center (Wired) Operational
Gary Stauffer Academic Building (GSAB) Network (Wired) Operational
Griswold Communications Center Network (Wired) Operational
Hach Student Life Center Network (Wired) Operational
Hantz Stadium Network (Wired) Operational
Jordan Hall Network (Wired) Operational
Miner Hall Network (Wired) Operational
NADA Auto Center & Hotel Network (Wired) Operational
Naegele Village Apartments Network (Wired) Operational
North Gate Network (Wired) Operational
North Village Apartments East Network (Wired) Operational
North Village Apartments West Network (Wired) Operational
Northwood IDEA Center Network (Wired) Operational
Northwood University Administration Center (NUAC) Network (Wired) Operational
Plaster Free Enterprise Center Network (Wired) Operational
Sloan Family Building Network (Wired) Operational
South Gate Network (Wired) Operational
Strosacker Library Network (Wired) Operational
Student Union / Bookstore Network (Wired) Operational
Midland On-Campus Network (Wired) Operational
Sunny Test Wired Network Operational
Midland Campus Wireless Network (WiFi) Operational
Adult Degree Program Building (ADP) Network (WiFi) Operational
Baseball Diamond Network (WiFi) Operational
Bennett Sports Center Network (WiFi) Operational
Church Family Administration Building (CFAB) Network (WiFi) Operational
DeVos Graduate School Network (WiFi) Operational
Doan Welcome Center / Admissions Network (WiFi) Operational
DuBois Hall Network (WiFi) Operational
Freedom Center (WiFi) Operational
Gary Stauffer Academic Building (GSAB) Network (WiFi) Operational
Griswold Communications Center Network (WiFi) Operational
Hach Student Life Center Network (WiFi) Operational
Hantz Stadium Network (WiFi) Operational
Jordan Hall Network (WiFi) Operational
Miner Hall Network (WiFi) Operational
NADA Auto Center & Hotel Network (WiFi) Operational
Naegele Village Apartments Network (WiFi) Operational
North Gate Network (WiFi) Operational
North Village Apartments East Network (WiFi) Operational
North Village Apartments West Network (WiFi) Operational
Northwood IDEA Center Network (WiFi) Operational
Northwood University Administration Center (NUAC) Network (WiFi) Operational
Plaster Free Enterprise Center Network (WiFi) Operational
Recognition Park Network (WiFi) Operational
Sloan Family Building Network (WiFi) Operational
Soccer Field Network (WiFi) Operational
Softball Diamond Network (WiFi) Operational
South Gate Network (WiFi) Operational
Strosacker Library Network (WiFi) Operational
Student Union / Bookstore Network (WiFi) Operational
Tennis Courts Network (WiFi) Operational
Midland On-Campus Network (WiFi) Operational
Sunny Test WiFi Operational
Program Center & Off-Campus Networks Operational
Alpena Program Center Operational
Boyne Mountain (Northwood Condo) Operational
Delta College Program Center Operational
Flint Program Center Operational
Ford Assembly Plant Kentucky Operational
Ford Truck Plant Kentucky Operational
Fort Worth Program Center Operational
Gaylord Program Center Operational
Lansing Program Center Operational
Livonia Program Center Operational
Louisville Program Center Operational
Macomb Program Center Operational
Selfridge Program Center Operational
Toyota Motor Manufacturing Indiana Operational
Toyota Motor Manufacturing Kentucky Operational
Troy Program Center Operational
Voice Services Operational
Mitel Telephones ? Operational
Voicemail Operational
Web Services Operational
Apply (apply.northwood.edu) ? Operational
Forms (forms.northwood.edu) Operational
nusites.northwood.edu Operational
Public Website (www.northwood.edu) ? Operational
Video Services Operational
Spectrum Cable TV Operational
Kaltura Kaltura MediaSpace Operational
Kaltura Platform Access Operational
Kaltura Video Conferencing Features Operational
Kaltura File Upload Operational
Kaltura Recording Operational
Kaltura Kaltura Meetings Operational
Kaltura Pitch Operational
Kaltura Quality of caption services Operational
Kaltura Processing Speed Operational
Kaltura Upload Speed Operational
Kaltura Upload Process Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
Monthly System Maintenance May 14, 2024 18:00 - May 15, 2024 08:30 EDT
To provide the best possible service, Information Technology (IT) will perform our scheduled monthly technology maintenance. This monthly maintenance program is a preventive measure that is essential to providing stable and secure systems to the University. While we take steps to keep the system online and usable, some of these activities require the affected systems and networks be shut down which may cause intermittent system interruptions.

Depending on the scope of scheduled maintenance, intermittent outages could include logging into Northwood-owned computers, my.northwood.edu, Wi-Fi, internet connectivity, personal and department share drives, online student enrollment application (apply.northwood.edu) and/or Perceptive Content.

Posted on Jan 08, 2024 - 10:53 EST
Monthly System Maintenance Jun 13, 2024 18:00 - Jun 14, 2024 08:30 EDT
To provide the best possible service, Information Technology (IT) will perform our scheduled monthly technology maintenance. This monthly maintenance program is a preventive measure that is essential to providing stable and secure systems to the University. While we take steps to keep the system online and usable, some of these activities require the affected systems and networks be shut down which may cause intermittent system interruptions.

Depending on the scope of scheduled maintenance, intermittent outages could include logging into Northwood-owned computers, my.northwood.edu, Wi-Fi, internet connectivity, personal and department share drives, online student enrollment application (apply.northwood.edu) and/or Perceptive Content.

Posted on Jan 08, 2024 - 10:54 EST
Monthly System Maintenance Jul 7, 2024 18:00 - Jul 8, 2024 08:30 EDT
To provide the best possible service, Information Technology (IT) will perform our scheduled monthly technology maintenance. This monthly maintenance program is a preventive measure that is essential to providing stable and secure systems to the University. While we take steps to keep the system online and usable, some of these activities require the affected systems and networks be shut down which may cause intermittent system interruptions.

Depending on the scope of scheduled maintenance, intermittent outages could include logging into Northwood-owned computers, my.northwood.edu, Wi-Fi, internet connectivity, personal and department share drives, online student enrollment application (apply.northwood.edu) and/or Perceptive Content.

Posted on Jan 08, 2024 - 10:47 EST
Monthly System Maintenance Aug 15, 2024 18:00 - Aug 16, 2024 08:30 EDT
Update - We will be undergoing scheduled maintenance during this time.
Jan 08, 2024 - 10:52 EST
Update - We will be undergoing scheduled maintenance during this time.
Jan 08, 2024 - 10:50 EST
Scheduled - To provide the best possible service, Information Technology (IT) will perform our scheduled monthly technology maintenance. This monthly maintenance program is a preventive measure that is essential to providing stable and secure systems to the University. While we take steps to keep the system online and usable, some of these activities require the affected systems and networks be shut down which may cause intermittent system interruptions.

Depending on the scope of scheduled maintenance, intermittent outages could include logging into Northwood-owned computers, my.northwood.edu, Wi-Fi, internet connectivity, personal and department share drives, online student enrollment application (apply.northwood.edu) and/or Perceptive Content.

Jan 08, 2024 - 10:48 EST
Monthly System Maintenance Sep 12, 2024 18:00 - Sep 13, 2024 08:30 EDT
Update - We will be undergoing scheduled maintenance during this time.
Jan 08, 2024 - 10:52 EST
Scheduled - To provide the best possible service, Information Technology (IT) will perform our scheduled monthly technology maintenance. This monthly maintenance program is a preventive measure that is essential to providing stable and secure systems to the University. While we take steps to keep the system online and usable, some of these activities require the affected systems and networks be shut down which may cause intermittent system interruptions.

Depending on the scope of scheduled maintenance, intermittent outages could include logging into Northwood-owned computers, my.northwood.edu, Wi-Fi, internet connectivity, personal and department share drives, online student enrollment application (apply.northwood.edu) and/or Perceptive Content.

Jan 08, 2024 - 10:49 EST
Monthly System Maintenance Oct 10, 2024 18:00 - Oct 11, 2024 08:29 EDT
To provide the best possible service, Information Technology (IT) will perform our scheduled monthly technology maintenance. This monthly maintenance program is a preventive measure that is essential to providing stable and secure systems to the University. While we take steps to keep the system online and usable, some of these activities require the affected systems and networks be shut down which may cause intermittent system interruptions.

Depending on the scope of scheduled maintenance, intermittent outages could include logging into Northwood-owned computers, my.northwood.edu, Wi-Fi, internet connectivity, personal and department share drives, online student enrollment application (apply.northwood.edu) and/or Perceptive Content.

Posted on Jan 08, 2024 - 10:50 EST
Monthly System Maintenance Nov 14, 2024 18:00 - Nov 15, 2024 08:30 EST
To provide the best possible service, Information Technology (IT) will perform our scheduled monthly technology maintenance. This monthly maintenance program is a preventive measure that is essential to providing stable and secure systems to the University. While we take steps to keep the system online and usable, some of these activities require the affected systems and networks be shut down which may cause intermittent system interruptions.

Depending on the scope of scheduled maintenance, intermittent outages could include logging into Northwood-owned computers, my.northwood.edu, Wi-Fi, internet connectivity, personal and department share drives, online student enrollment application (apply.northwood.edu) and/or Perceptive Content.

Posted on Jan 08, 2024 - 10:54 EST
Monthly System Maintenance Dec 17, 2024 18:00 - Dec 18, 2024 08:30 EST
To provide the best possible service, Information Technology (IT) will perform our scheduled monthly technology maintenance. This monthly maintenance program is a preventive measure that is essential to providing stable and secure systems to the University. While we take steps to keep the system online and usable, some of these activities require the affected systems and networks be shut down which may cause intermittent system interruptions.

Depending on the scope of scheduled maintenance, intermittent outages could include logging into Northwood-owned computers, my.northwood.edu, Wi-Fi, internet connectivity, personal and department share drives, online student enrollment application (apply.northwood.edu) and/or Perceptive Content.

Posted on Jan 08, 2024 - 10:54 EST
Past Incidents
Apr 19, 2024

No incidents reported today.

Apr 18, 2024

No incidents reported.

Apr 17, 2024

No incidents reported.

Apr 16, 2024
Completed - The scheduled maintenance has been completed.
Apr 16, 12:30 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 16, 12:00 EDT
Scheduled - IT will be performing systems maintenance on the Colleague environment. The following systems or applications will be unavailable during the maintenance outage: Colleague and Self Service including Student Planning, Make A Payment, Faculty Attendance, Faculty Midterm and Final Grades, Earning Statements and Tax Information.
Apr 16, 09:19 EDT
Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024
Completed - The scheduled maintenance has been completed.
Apr 12, 08:30 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 11, 18:00 EDT
Scheduled - To provide the best possible service, Information Technology (IT) will perform our scheduled monthly technology maintenance. This monthly maintenance program is a preventive measure that is essential to providing stable and secure systems to the University. While we take steps to keep the system online and usable, some of these activities require the affected systems and networks be shut down which may cause intermittent system interruptions.

Depending on the scope of scheduled maintenance, intermittent outages could include logging into Northwood-owned computers, my.northwood.edu, Wi-Fi, internet connectivity, personal and department share drives, online student enrollment application (apply.northwood.edu) and/or Perceptive Content.

Jan 8, 10:52 EST
Apr 11, 2024
Apr 10, 2024

No incidents reported.

Apr 9, 2024

No incidents reported.

Apr 8, 2024

No incidents reported.

Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024

No incidents reported.