Intermittent Make-A-Payment Failures
Incident Report for Northwood University
Resolved
This incident has been resolved.
Posted Jan 05, 2021 - 08:10 EST
Investigating
Make-A-Payment is currently experiencing intermittent credit card failures. End-users may receive the error "An error has occurred during the payment process, please try again later." when trying to complete their payment.

Northwood IT has engaged the vendor and is currently working to resolve this issue.
Posted Jan 04, 2021 - 19:48 EST
This incident affected: Application Services (Make-A-Payment).